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CHAPTER-I

INTRODUCTION TO STAAD Pro. ENVIRONMENT

STAAD Pro. Stands for Structural Analysis And Design Program

All structural analysis software generally consists of three parts:
= Pre Processing: Generates the model, assembles and organizes all data needed for the analysis.
= Processing: Calculates displacements, member forces, reactions, stresses, etc.
= Post Processing: Displays the results.

STAAD.Pro Workflow Process:

The process of modeling and designing in STAAD.Pro can be summarized into the following general
workflow process, which is suggested inherently by the on-screen organization of the tabs within the
program:

1. Basic Geometry: Define the basic geometry of the structure using beams, columns, plates
and/or solid elements.

2. Section Properties: Define the sizes of members by width, depth, cross sectional shape, etc.

3. Materials Constants: Specify material such as timber, steel, concrete, or aluminum to define
Poisson’s Ratio, Coefficient of Thermal Expansion, density, etc.

4. Member Specifications: Define member orientations, member offsets, member releases where
moment transfer is to be limited or eliminated, and conditions that only allow a partial

transfer of certain types of forces such as tension-only.

5. Supports: Define support locations and boundary conditions including moment fixity, support
stiffness, and support angle.

6. Loads: Assign loads such as self-weight, dead, live, wind and seismic, and define load
combinations.

7. Analysis Instructions: Indicate the type of analysis to be performed (regular analysis, P-delta,
Buckling, Pushover, etc.) and define associated options.

8. Post Processing Commands: Extract analysis results, review deflected shapes, prepare shear
and moment diagrams, generate tables to present results, etc.

9. Design Commands: Specify (for steel, concrete, timber, etc.)
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The STAAD.Pro Start Page is displayed as following
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Fig 1.1: Start Page of STAAD Pro.

STAAD Pro. key features:
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Fig 1.2: For STAAD Pro. Key features
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Some most Usable Toolbars and icon views:

Whole section view 3D Rendered view
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Elevation view Plan view
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Add beam cursor Modeling view Post processing mode
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Symbols and Levels
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Fig 1.3: STAAD Pro. Toolbars and icon views
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Fig 1.4: Supports Page

Fig 1.4: Load & Definition Page




CHAPTER-II

CROSS SECTIONAL SHAPES FOR VARIOUS FINITE ELEMENTS

General

To design a building structure, bridge structure or any other structures use multiple elements that can be
characterized as beams, columns, trusses etc. These structural elements have some cross-section size and
shape to build up the total shape of the structures. The behavior of a structural member is dictated by its
material, cross sectional size and shape of the elements and its geometry. Depending on different
materials they have different cross sectional shape;

e Rectangular Section
e T-Section

e |-Section

e Channel-Section

e Circular-Section

e Triangular Section
o Wide flanged Shape
e Standard Channel

e Angle

e Structural Tee etc.
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Rectangular Section T-Section I-Section Channel-Section  Circular-Section
ey
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w C L WT or ST

Tri I i .
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Fig: 2.1 Two dimensional cross section of various finite elements



= Some American Standard Steel cross-sections and their properties
1. Angles - Equal Legs
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Dimensions Static Parameters
Size
(in x in) Depth(h) Thickness(s) | Sectional Area | Weight [Moment of Inertia(l)
(in) (in) (in?) (Ibs/ft) (in%)
12 13/8 30.9 105 410.0
12 11/4 28.3 96.4 3775
12 x 12
12 11/8 25.6 87.2 344.1
12 1 22.9 77.8 310.4
10 13/8 25.6 87.1 232.1
10 11/4 235 79.9 215.1
10 11/8 21.2 72.3 196.2
10x 10
10 1 19.0 64.7 177.3
10 7/8 16.7 56.9 157.6
10 3/4 14.4 49.1 137.2
8 11/8 16.7 56.9 98.0
8 1 15.0 51.0 89.0
8 718 13.2 45.0 79.6
8x8 8 3/4 11.4 38.9 69.7
8 5/8 9.6 32.7 59.4
8 9/16 8.7 29.6 54.1
8 1/2 7.8 26.4 48.6
6 1 11.0 374 35.5
6 718 9.7 33.1 31.9
6 X6
6 3/4 8.4 28.7 28.2
6 5/8 7.1 24.2 24.2



https://www.engineeringtoolbox.com/area-moment-inertia-d_1328.html

2. American Standard Steel Channels:

W
Static Parameters
Designation Dimensions
Moment of Inertia|Elastic Section Modulus
Depth| With .
Imperial | -h- [-w- Thic\li\:leel;s ©) Seg\trlggal Weight Ix ly Sx Sy
(inx Ib/ft) | (in) | (in) . - (Ibs/ft) (in%) (in%) (in®) (in®)
(in) (in%)
C15x50 | 15 |3.716 0.716 14.7 50 404 11.0 53.8 3.78
C15x40 | 15 [3.520 0.520 11.8 40 349 9.23 46.5 3.37
C15x33.9| 15 |3.400 0.400 9.96 33.9 315 8.13 42.0 3.11
C12x30 | 12 [3.170 0.510 8.82 30 162 5.14 27.0 2.06
C12x25 | 12 |3.047 0.387 7.35 25 144 4.47 24.1 1.88
C12x20.7| 12 |2.942 0.282 6.09 20.7 129 3.88 21.5 1.73
C10x30 | 10 |3.033 0.673 8.82 30 103 3.94 20.7 1.65
C10x25 | 10 |2.886 0.526 7.35 25 91.2 3.36 18.2 1.48
C10x20 | 10 |2.739 0.379 5.88 20 78.9 2.81 15.8 1.32
C10x15.3| 10 |2.600 0.240 4.49 15.3 67.4 2.28 13.5 1.16
C9x20 9 |2.648 0.448 5.88 20 60.9 2.42 13.5 1.17
C9x15 9 |2.485 0.285 441 15 51.0 1.93 11.3 1.01
C9x134 | 9 [2.433 0.233 3.94 134 47.9 1.76 10.6 0.96
C8x18.75| 8 |2.527 0.487 5.51 18.75 44.0 1.98 11.0 1.01
C8x13.75| 8 [2.343 0.303 4.04 13.75 36.1 1.53 9.03 0.85



https://www.engineeringtoolbox.com/american-standard-steel-channels-d_1321.html

3. American Wide Flange Beams:

Y
N |
|
e : —
|
$
|
= ———thp————= X
|
|
|
|
- I \
N |
p W A
Static Parameters
Designation Dimensions Moment of | Elastic Section
Inertia Modulus
Imperial Metric Depth |Width Web Sectional .
I Thickness Weight| I« ly Sx Sy
(inxinx | (mmxmmx | -h- [-w- - Area (ka/m) | em?) | cm*) | cm¥) | em?)
Ib/ft) kag/m) (mm) | (mm) (cm?) g
(mm)
W4x4x13 W10§)9x3100x 106 | 103 | 7.1 247 | 19.3 |475.9|160.6| 89.9 | 31.2
W 5x5x16 W13§3x8130x 127 | 127 | 6.1 304 | 238 |8855| 311 |1395| 49
W5 x5 x 19 W1338X113°X 131 | 128 | 6.9 35.9 | 28.1 | 1099 |381.4|167.7| 596
W6X4X 9 W15§)3x5100x 150 | 100 | 43 173 | 135 |6855| 918 | 91.4 | 184
W6 x4 x12 W1538X01°°X 153 | 102 | 5.8 229 | 18 |915.9|125.9|122.1| 254
W6 x4x16 W15§4X0100X 160 | 102 | 6.6 306 | 24 |1342|1826|167.8| 358
W 6 X 6 x 15 W1522X5150X 152 | 152 | 5.8 286 | 22.5 | 1206 |386.6]| 158.6 | 50.9
W 6 X 6 X 20 W15§9X8150X 157 | 153 | 6.6 379 | 298 | 1714 |5555| 2184 | 72.6
W 6 X 6 X 25 W15§7X1150X 162 | 154 | 8.1 474 | 371 |2220|706.8|274.1| 91.8

= Modulus of Elasticity of Concrete:



https://www.engineeringtoolbox.com/american-wide-flange-steel-beams-d_1318.html

According to ACI Code the modulus of elasticity of concrete E ¢ can be calculated by the formula given
below:

E, =33 W.'® \/fi psi (1b/in?)
Or, E, = 0.04 W,.1° \/Z MPa (N/mm?)
With normal-weight, normal-density concrete these two relations can be simplified to
E.= 57000\/; psi (1b/in?)
E.= 4700\/; MPa (N/mm?)

Where,

Ec = Modulus of elasticity of concrete (Ib/in?) or MPa
f 'C = Specified 28-day compressive strength of concrete (1b/in?) or MPa
Wc = Concrete Weight.

CHAPTER-III

TWO DIMENSIONAL PORTAL FRAMES
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Objective: Analyze the following Two Dimensional Portal frame (Fig: 3.1) under vertical and horizontal
loads and find out the following values;

1. Support reactions

2. Shear Force and Bending moment on member CD

3. Displacement (Deflection) of point B, C, D, E

50 kip
L D
7!_6" L {3}64
. 2
=
=
T 1 E
2 1 - 20 kip
3:

LA JWE

' 120" 150" 124" ‘

Fig: 3.1

Properties:
Materials= Concrete
Section Size = 157X 15”

Procedure:
1. Geometry (Model creating):

1.1 Open STAAD Pro. software ->File > New - Click on Space - Write the File Name and select
Location—> Length Units = Foot, Force Units = Kilo Pound > Next ->Add Beam ->Finish.( Fig:
3.2)

1.2 Now close the Default Grid window -> Input the coordinates for point A (X=0, Y=0,Z=0), B
(X=0, Y=10, Z=0), C (X=12, Y=20, Z=0), D (X=27, Y=20, Z=0), E (X=39, Y=10,Z= 0), F
(X=39, Y=0,Z=0), Then click on Geometry ->Add Beam ->Add Beam from point to point. (Fig:
3.3) & (Fig: 3.4)

11



New X ||Where do you wantto go ?
Add Beam
_ [(J4dd Plate
irace File Name: [JAdd Sold
0 Flane |BEAI'I'1| | [(Open Structure Wizard
oor []Open STAAD Edior
[ Truss Location: [CJEdit Job Information

|D:\CEE LAB Documents\8. Lab Clas|

any plane, is the most general.

A SPACE structure, which is a three-dimensional framed structure with loads applied in

Begin buiding your model by creating new joints and beams using the construction grid,

drawing tools and spreadshests.
Length Units Force Units

Olnch (O Decimeter (0 Pound (O Newton

(®) Foot ) Meter (® KiloPound () DecaMewton

O Milimeter O Kilometer OFKiogram O KioNewton

() Centimeter (O Metic Ton () MegaNewton

<Back Next > Cancel Help e e e
Fig: 3.2
L]
3 4
1 Structurel - Nodes @lﬂl[ﬁ]
X Y z
-2 Hode & ft f
1 0.000 0.000 0.000
2 0.000 10.000 0.000
3 12.000 20.000 0.000
4 27.000 20.000 0.000
3 35.000 10.000 0.000
6 35.000 0.000 0.000
7
L]
1
Fig: 3.3
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Geometry Commands  Analyze Mode
Modes

. . :
spapCndibocs Set Mew Member Attributes...
¥ Insert Node...

P4 Beam from Point to Point
Add Plate 4 o . .
Add Solid , J+ Add Beam between Mid-Points
¥4 Add Surface
Create Colinear Beams
Connect Beams Along L4 -__l;"'r Add Curved Beam
Create Infill Plates

T Add Beam by Perpendicular Intersection

Create Parametric Models...

ot Translational Repeat...
@ Circular Repeat...
€ Generate Surface Mesh
Generate Plate Mesh
Generate Slab/Wall Connection
Move... L4
(== Rotate...
4+ Mirror...

Stretch Selected Member(s)

Intersect Selected Members g
Merge Selected Members

Merge Selected Modes

Renumber 4
Split Beam

Break Beams at Selected Nodes

Run Structure Wizard

Fig: 3.4

2. General (Define & Assign):

2.1 Property: Define - Rectangle ->Material = CONCRETE - YD = 1.25 ft (15”), ZD =1.25 ft
(15”) > Add > Close then for Assign select the property and click on Assign to View = Assign
- Yes. (Fig: 3.5)

2.2 Support: Create > Fixed >Add. (Fig: 3.6)

Now for Assign click on the Support type - Select the Support point in Beam - Assign to
Selected Nodes > Assign = Yes.

2.3 Load & Definitions: Load Cases Details 2 Add - Loading Type = Dead > Title = Dead Load
or DL > Add - Again Loading Type = Live > Title = Live Load or LL - Add - Close. (Fig:
3.7)

e DL >Add - Self weight = Direction =Y, Factor = -1->Add —>Close. Then
SELFWEIGHT Y-1 > Assign To View > Assign > Yes. (Fig: 3.8)

e For Given loads: Again Live Load or LL - Add ->Member Load ->Uniform Force
—>W1 = -15 kip, d1= 0 ft, d2=8 ft > Direction = Y(Local) - Add —>Close, then click on
defined force and select the required Beam - Assign to selected Beams - Assign > Yes.
(Fig: 3.9 & Fig: 3.10)

e The same process follow for other Trapezoidal, Concentrated and Uniform distributed
forces.

e Load Combination: Load Cases Details - Add —>Define Combinations ->Name =
DL+LL —>Default ai = 1, then select DL, LL and click on >> to send right side from left
side. (Fig: 3.11)
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‘% & B Generd
" n B Tapered | 20—
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= & E Agsign Profile YD: i
= [=9
E i Highlight Assigned Geometry
= Edt. Delete...
| §
'%E? E Values.. Section Database Define... Mateti
% 3 Materals... Thickness... User Table... CONCRETE v
z E Assigrment Method
& -
] 1 Aasign To Selected Beams (7) Use Cursor To Assign
= (7) Assign To Edi List (®) Assign To View
2l o
3| 8
o) &
I =
E Cosz Heb Aazign Cloge
Fig: 3.5
B Supports - Whole Str = || Create Support >
Ref Description Foundation Inclined Tension/Compression Only Springs.
51 Mo support >< Fixed Pinned Fixed But Enforced Erforced But  Muttiinear Spring
52 Support 2 é#
53 Support 3 E_-?Q
Releases
Fx Mx
] MY
Edit Create Delete U Fy
Assignment Method E7 Mz
Assign To Selected Modes i
() Assign Tao View
(®) Use Cursor To Assign
() Assign To Edit List
Assign Close Help
Cancel Assign Help

Fig: 3.6
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Load & Definition

+-[D) Definitions
~[L] Load Cases Details

New... Edit .

[ Toggle Load

Assignment Method
Aesign To Selected Entities
Assign To View

Use Cursor To Assign
Assign To Edit List

b Load Generation
B Define Combinations
i Ato Load Combination

Delete

Assign Cloze

Help

Number Loading Type : | Dead v

Reducible per UBC/IBC

Tte L

Add

Close Help

Fig: 3.7

Add New : Load ltems

@ Sefneioht

@ Nodal Load

@ Vember Load

@ Physical Member Load
@ frea Load

@ Floor Load

@ Plate Loads

@ Surface Loads

@ Soid Loads

@ Temperature Loads
@ Seisnic Loads

@ Time Htory

@ Vind Load

@ Snow Load

@ Response Spectra
@ Repeat Load

@ Frequency

; Load & Definttion

Direction

Ox Ok

# (D Defiiions

1[5 Load Cases Detail

0z N=RRR
- LAFTETEE

—_—

Factor |-

New... Add... Edit ... Delete..
[ ] Toggle Load
Assignment Method
Assign To Selected Beams/Plates () Use Cursor To Assign
(®) Assign To View (7) Assign To Edt List
Aasign Close Help

Fig: 3.8
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@ Sefweight
@ Nodal Load
@ Member Load
-----
----- B Uniform Moment
----- E Concertrated Force
----- E Concertrated Momen
----- H Linear Varying
----- E Trapezoidal
----- B Hydostatic
----- h Pre/Post Stress
----- i Ficed End
@ Physical Member Load
@ Area Load
@ Floor Load
@ Flate Loads
@ Surface Loads
@ Solid Loads
@ Temperature Loads
@ Seismic Loads
@ Time History
@ Wind Load
@ Snow Load
@ Response Spectra
@ Repeat Load
@ Frequency

W1

a4

Force

Direction

(O X (Local)
(®) (Local)
(OZ (Local)

OGX
OGy
OGZ

OPx
OPY
QPrz

Load & Definition X

Definitions
= [ Load Cases Details
ERRRI

b SELFWEIGHT Y -1
2@ 2:LL

Mew... Add... Edit ...
[ Toggle Load
Assignment Method

(®) Assign To Selected Beams
(") Assign To View

Delete...

() Use Cursor To Assigi
() Assign To Edt List

| Assign | Close Help

Fig: 3.9
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Fig: 3.10
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Add Mew : Load Cases

E Primary
E Load Generation

Define Combinations

B Auto Load Combination

g

Load No: Mame : |DL+LL |

Type
(®) Normal General Format :‘ -8 * L,
() SRSS
Factor 1 SRSS Component
(O ABS

Generate Combination

Available Load Cases:

Load Combination Definttion: [S] = SRSS

Load Cases |

| Factor |

2L

3>

<<

Close

Fig: 3.11

Analysis and Result:
From left side click on Analysis/Print - Static Check or All >Add > Close
At Menu bar - Analyze > Run Analysis > Go to post processing mode ->Done > Selected load

cases = DL+LL >Apply >OK. (Fig: 3.12 & Fig: 3.13)

For Support Reactions use node cursor and double click on the support point >Reactions. Then

get the Table for all Support Reactions. (Fig: 3.14)

For Beam Forces: From left side click on Beam —>Graphs the find out Bending moment, Shear
force, and Axial force by clicking on required Beam from the following. ( Fig: 3.15)

For Displacement (Deflection) of point go to Result (from Menu bar) - Deflection. use node
cursor and Double click on the required point by using Node cursor > Displacements. Then get

the Table for all Node Displacements. (Fig: 3.16)

Analyze Mode Window Help
I ||masfral il 7 AT B
Bz
[ ++ Processing Global Stiffness Matrix. 13:47:32 »~
++ Finished Processing Global Stiffness Hatriz. 150 m=s
- ++ Proceszszing Triangular Factorization. 13:47:32
E ++ Finished Triangular Factorization 100 m=
= ++ Calculating Joint Displacement . 13:47:33
J ++ Finished Joint Displacement Calculation. 160 ms
++ Calculating Member Forces. 13:47:33
++ Analy=i= Succes=fully Completed ++
++ Creating Displacement File (DSP). .. 13:47:33
++ Creating Reaction File (REA) . .. 13:47:332
++ Calculating Section Forces1-110. 13:47:32
++ Calculating Section Force=?2 13:47:33
++ Calculating Section Force=3d 13:47:33
++ Creating Section Force File (BHD) . .. 13:47:332
++ Creating Section Displace File (SCH) . .. 13:47:34
++ Done 13:47:34
0 Errori{s). 2 Warning(s). 0 Hoteis)
++ End STAAD Fro Run Elap=ed Time = 4 Sec=
B-2.anl
™
< >
() %iew Output File
@ (®) Goto Post Processing Mode
(2 Stay in Modeling Mode Dane

Fig: 3.12

17



esults Setup =
loads Range Result View Options
Defined Envelopes
(® Envelope of Load Cases in Selected List
Load Cases
Available: Selected:
1DL 30L+LL
2LL
>
<
<<
Apply Help
Fig: 3.13
11 B-2 - Support Reactions:
Node | 4[] All 4, Summary 4, Envelope /
Horizontal | Vertical | Horizontal Moment
Node: 2 6.000 Node uc Fx Fy Fz Mx My
0.000 Kip Kip i ip-i Kip-in
0.000 2 0 4
Tables 3 |3DLelL
Nodes Loads 4 | 3DL+LL 0.000 28995
5 |3DL+LL 0.000 56.037 0.000 ; -1384.058
Supports Reactions
Displacements
% Unit: ft
Close
Fig: 3.14
— o e ] | -1 Ce=
o Mz(kip-in)
6000 Joid 6000
4000 4000
2000 2000
3] T n
\ 2000 s ‘—‘_7:--_-_-:5-5?:2“””
4000 Emn
6000 6000
A [Elo)=
Fy(kip)
80 :70‘2 7BI]
4U§ ; 5‘554"
- — %
] 5 10 15-
407 En
80 80
\ =
\‘. Fx(kip)
200 4163 163200
% 100 ] -mn
S , ; ]
B 5 10 5
100 1 an
200- -200

Load 3: Shear Y : Bending 7 :

Fig: 3.15
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il |
[ 4] »[»/]s AllA Summary /
Horizontal Vertical Horizontal | Resultant Rotational
X Y z rX Yy rZ
Node Lc in in in in rad rad rad
1 3DL+LL 0.000 0.000 0.000 0.000 0.000 0.000 0.000
3 JDL+LL -4.154 1.964 0.000 4595 0.000 0.000 -0.008
4 3 DL+LL -4.196 -2.104 0.000 4.694 0.000 0.000 -0.01%9
5 30L+LL =251 -0.035 0.000 2512 0.000 0.000 0.037
6 3DL+LL 0.000 0.000 0.000 0.000 0.000 0.000 0.000
B Frame - Node *
Node
Node: 2 X: 0.000
Y: 10.000
Z: 0.000
Tables
MNodes Loads
Supports Reactions
Displacements;
Unit: ft
Close
Fig: 3.16
*kkkkk
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Assignment-01:
Analyze the following 2D Portal frame under vertical and horizontal loads and find out the following
values;

a) Support reactions

b) Displacement (Deflection) of point B, C, D

c) Shear Force and Bending moment on member BC

8 kip/ft

AVAVAVAVAVATAVIINN

C - TI_OI! D_

\'1»@\%

8‘ Ll

— 5 :
20 kipl T fg

>

g 12-0" 134" /%)%

Fig: 3.17
Properties:
Materials= Concrete
Section Size = 127X 127

Assignment-02:
Analyze the following 2D Portal frame under vertical and horizontal loads and find out the following
values;

a) Support reactions

b) Displacement (Deflection) of point B, C, D

c) Shear Force and Bending moment on member BC

12 kip/fi
YYYYYYYYY YY VY

i
™~
100"

ol 6!_0" 12!_0"
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Fig: 3.18
CHAPTER-IV

TRUSS ANALYSIS

A. Roof Truss

Objective: Analyze the following Roof Truss (Fink Type) and find out the following values;
1. Support reactions
2. Forces for the members a, b, c, d, e, f

I e e L A U | A
Wkip
Wp

Wkip

20 kip

Fig. 4.1: Two Dimensional View of the Roof Truss (Fink Type)
Properties:
Materials= Steel
All members are Japanese Angle = L 60X60X4
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Fig. 4.2: Three Dimensional View of the Roof Truss (Fink Type)

Procedure:
1. Geometry (Model creating):

1.1 Open STAAD Pro. software >File = New - Click on Truss ->Write the File Name and select
Location—> Length Units = Foot, Force Units = Kilo Pound > Next > Add Beam ->Finish.(Fig:

4.3)

1.2 Now close the Default Grid window = input coordinates value for all nodes like 1% Node point
(X=0, Y=0,Z=0), 2" Node point (X=10, Y=5,Z=0), 3" Node point (X=12, Y=0,Z=0), 4" Node
point (X=20, Y=10,Z2=0), 5" Node point (X=24, Y=0,Z=0) and similarly others nodes Then click
on Geometry ->Add Beam ->Add Beam from point to point. (Fig: 4.4) & (Fig: 4.5)

1.3 Now Select the Nodes 1 & 11 (in View window) by using node cursor - Translational Repeat >
Global Direction =Y - No. of Steps = 1 - Spacing= -10(-ve) - Click on Link Steps = OK

|D:'-CEE LAB Documents'8. Lab Clas|

(Fig: 4.6)
MNew X | [Where do you want to go 7
Add Beam
[5pace File Mame: [JAdd Plai.e
[JPlane [ Add Solid
JFoor | Roof truss ‘ [CJopen Structure Wizard
[(JOpen STAAD Editor
Location: [ Edit Job Information

and no bending in the members

A TRUSS structure consists of truss members which can have only axial member forces

Length Units

Force Units

drawing tools and spreadshests.

Begin building your model by creating new joints and beams using the construction grid,

(inch () Decimeter () Pound () Newton
(®) Foot () Meter ® KloPound () DecaNewton
() Milimeter () Kilometer O Kiogram O KiloNewton
(O) Centimeter O Metric Ton (O MegaNewton
¢ Back MNext > Cancel Help < Back Cancel Help
Fig: 4.3
'8 T Roof truss - Nodes EI@
X Y z
R Node & & #
10 i o0 oo 00
. 2 10.000 5.000 0.000
1 3 200 oo00; 00w
'4 4 20.000 10.000 0.000
5 24.000 0.000 0.000
.9 6 30.000 15.000 0.000
7 35.000 0.000 0.000
L] 40.000 10.000 0.000
17 9 43.000 0.000 0.000
10 50.000 5.000 0.000
11 60.000 0.000 0.000
) \ 2
.
1
Fig: 4.4
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CEE 330L: Structural Analysis and Design Lab, NSU

Geometry Commands  Analyze Mode
Modes
Snap/Grid Mode 4

& Trsert Node.. Set Mew Member Attributes...

Add Plate

ﬁkdd Beam from Point to Point
Add Solid >

$21 Add Surface % Add Beam between Mid-Points

-

Create Colinear Beams

Connect Beams Along » | T Add Beam by Perpendicular Intersection
E Create Infill Plates F+/lr Add Cuwed Eeam

Create Parametric Models...

uﬁ\ Translational Repeat...
@~ Circular Repeat...

€R Generate Surface Mesh
Generate Plate Mesh
Generate Slab/\Wall Connection

Move.. g
(=» Rotate...
- Mirror...

,-\ Stretch Selected Member(s)

Intersect Selected Members L4
Merge Selected Members

Merge Selected Modes

Renumber L4

Split Beam
Break Beams at Selected Modes

Run Structure Wizard

Translational Repeat X

1|00 Cancel
Help

(] Renumber Bay
Link Steps

(Open Base
Generation Flags

Global Direction No ofSteps -E @Nl OGeometryOnly

Ox @y Oz Defaut Sten Spacmg ft (O Geometry and Propery Orﬂy@v\
9 Kk

Fig: 4.6
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2. General (Define & Assign):
2.1 Property: Section Database ->Japanese> Angle> L60X60X4 ->Material = STEEL-> Add
—>Close then for Assign select the property and click on Assign to View ->Assign = Yes. (Fig:
4.7)
2.2 Support: Create >Fixed >Add > Now for Assign click on the Support type —>Select the
Support point in Truss > Assign to Selected Nodes > Assign > Yes.
2.3 Translational Repeat: Now Select the whole structure (in View window) by using beam cursor
> Translational Repeat - Global Direction =Z - No. of Steps = 6 - Spacing= 15 - Click on
Link Steps - OK and then delete extra beams (Fig: 4.8)
2.4 Load & Definitions: > Load Cases Details > Add > Loading Type = Dead ->Title = Dead
Load or DL > Add - Loading Type = Live > Title = Live Load or LL - Add -> Close.
e DL —>Add ->Self weight ->Direction = Y, Factor = -12>Add ->Close. Then
SELFWEIGHT Y-1 2> Assign To View 2> Assign > Yes. (Fig: 4.10)
o For Given loads: Again Live Load or LL >Add ->Nodal Load - Fy = -30 kip >Add >
Fy = -20 kip—>Add —>Close, then click on defined force and select the required Nodes =
Assign to selected Nodes > Assign > Yes. (Fig: 4.11)
2.5 Load Combination: Load Cases Details - Add ->Define Combinations *Name = DL+LL
->Default ai = 1, then select DL, LL and click on >> to send right side from left side. (Fig: 4.12)
g ? 1" Properties - Whole Structure X g ?;f:cp:a“ A _
f & || Section Beta Ange gi;;“:” Select Angle
o S
. @ British 2542543 A Type Specification
T || Ref Section Wateria @ Canadian L30%30%3 . .
g —I| T CONCRETE @Chinese LA0XA0X3 (® 5T (Single Section from Table)
E §_ @Dulch L45K45%4 (O RA (Single Angle w/Reverse Y-Z As)
(% @ @ European LADX40%5
n @ French L50X50%4 (OLD (Long Leg Back to Back, Double Angle)
B |- & Geman LA5KI5X5 (0)SD (Short Leg Back to Back, Double Angle)
= @ Indian Le0X60X4
5| 8 @ Jpanese LBOX50%5
3| g B HShaps L50X50%6 v
E 1] E IShaDI: Voo Tae (D) SA (Star angle amangement, Double Angle)
E’ i WIHighlight Assigned Geometry | - B 7Shape
-l Edt Delet ____E| e
L ~ »
E.E' E Valugs... Section Database Define... -l Pipe
@ B - [ Rectangular Hollo
% - Wateals... Thickness... User Table... E gﬂualfe n°||||°W
% E Assignment Method é".nnda;muar o
i A Pssign To Selected Beams () Use Cursor To Assign @Me‘i?a”.
|- () Assign To Edt List (®) Assign To View ggﬁ::::: ::(:?C?ESCW
F| = @Somhﬁ«fﬁoan
il 2] | |
o| & ??outh!{orean v
- g < »
B E Close Heb Assign Close Help
Fig: 4.7
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Add Mew: Load Ttems

@ Sefweight

@ Noda Load

@ Member Load

@ Physical Member Load
@ frea Load

@ Floor Load

@ Plte Loads

@ Surface Loads

@ Soid Loads

@ Temperature Loads
@ Seismic Loads

@ Time Higtory

@ Vind Load

@ Snow Load

@ Response Spectra
@ Repeat Load

@ Frequency

Direction

Ox @ 0Oz

Factor |1

Fig: 4.10

Load & Definttion

#[D) Defiritions
-|Ly Load Cases Details
=10

Load Envelopes

P8 SELFVEIGHT Y-

New... Add..

[ ] Togge Load
Assignment Method

(®) Assign To View

Edt ..

Delete...

Assign To Selected Beams/Plates () Use Cursor To Assign

() Assign To ot List

Assign

Close

Help
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CEE 330L: Structural Analysis and Design Lab, NSU

Add New : Load ftems Load & Definition -
) - Definiti

¢sic | (W | |- B e oot

m Lo IE 1: Seffwt

| Node el SELFWEIGHT Y A1

| . =R I_Ll 2:LL

. [§ Support Displacemen e FY-30kipht
@ Member Load g
@ Physical Member Load [0 Load Envelopes
@ fes Load a0 o mD et
@ Floar Load
@ Plate Loads , ,
@ Surface Loads y klp My D kit
@ Sold Loads
@ Temperature Loads = kip Mz kipt ! '
@ Seismic Loads D EI
@ Tine Hstory b )
@ Viind Load
@ Snow Load MNew... Add... Edit ... Delete...
@ Response Spectra E;jrg"ngrs;'-‘:;ho 4
@ HEDEET Load (®) Assign To Selected Nodes () Use Cursor To Assign
@ FI'EC]LIEHC)’ () Assign To View (") Assign To Edit List

|
Close Help

Fig: 4.11

Add Mew : Load Cases

g P (Dotine Comboations

H Load Generation
[

Bl Define Combinations Load Mo: Name : |DL+LL |
B “uto Load Combination Type
(®) Nomal General Format :| «, * 1,
) SRsS
O 8BS Factor El SR5S Component
Defautt . _ Generate Combination
Available Load Cases: Load Combination Defintion: [5] = SRS5
LoadCases | | Factor |
2 LL
=
53
<<
<
Add Close
Fig: 4.12
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Analysis and Result:
From left side click on Analysis/Print - Static Check or All > Add > Close
At Menu bar - Analyze > Run Analysis > Go to post processing mode ->Done > Selected load

cases = DL+LL 2> Apply >OK. (Fig: 4.13 & Fig: 4.14)

For Support Reactions use node cursor and double click on the support point ->Reactions. Then

get the Table for all Support Reactions. (Fig: 4.15)

For Beam Forces: From left side click on Beam - Graphs the find out Axial force by clicking on

required Beam from the following (Fig: 4.16)

Analyze Mode Window Help

N | (o ||| 7 oae aE e AT e B

? BB E Y

N

() Stay in Madeling Mode

Ex
++ Processing Global Stiffness Matri=. 1323:47:32
++ Fini=hed Proces=ing Glabal Stiffnes=s Matrix. 150 m=
++ Process=ing Triangular Factorization. 13:47:32
++ Finished Triangular Factorization. 100 m=
Calculating Joint Displacement . 1323:47:22
++ Fini=hed Joint Di=placement Calculation. 160 m=
++ Calculating Member Forces. 13:47:33
++ Analy=sis Succes=sfully Completed ++
++ Creating Displacement File (DSPY . . 1323:47:22
++ Creating Reaction File (REA) . . . 13:47:33
++ Calculating Section Forces=1-110. 13:47:33
++ Calculating Section Force=sZ2. 13:47:33
++ Calculating Section Force=3 1323:47:22
++ Creating Section Force File (BHD)Y . . . 13:47:33
++ Cresating Section Displace File (SCHY O . 13:47:34
++ Done. 12:47:34
0 Errori{i=). 2 Warningi(=). 0 Hotel(=)
++ End STAAD Pro RFun Elap=s=ed Time = 4 Sec=
B—2 anl
£ >
() Wiew Output File
@ (®) Go to Post Processing Maode
Done

Fig: 4.13

esults Setup
loads Range Result View Options

Defined Envelopes
(®) Envelope of Load Cases in Selected List

>>

<<

Load Cases

Available: Selected:
10L ) 3DL+HL
2LL :

Aoply

Help

Fig: 4.14
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| |
™
B Roof truss - Node x T
Node [{[» ]\ All £ Summary 3 Envelope /
. Horizontal | Vertical | Horizontal Moment
Node: 12 X 000 Fx Fy Fz Mz
Y. -10.000 Node LIC ; ; . -
kip kip
Z 0.000
Tables
13 [3DL+LL
Modes Loads
Digplacements
Lnit:
Close
Fig: 4.15
F EEE=E] EEE]
3 k3 Mz(kip-in)
- 002 0.02
E 0.0 0.01
e 25 5 7 10 112
§ .. 001 [nm
% 2 002 002
s F s
E% Fy(kip)
a

0.02 0.02
[0.012

(2 0.0

4 T T T &
25 5 75 10 N2

(2 0.0
0012

0.02 0.02

| Roof truss - Beam Graphs - Beam 3 == =
Fa(kip)
100 89.9 89.8, 100
] 2] B 0
a7 T 16
2 7 10 12-
50 50

;—X Load3 100 100
Fig: 4.16
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B. Bridge Truss

Objective: Analyze the following Bridge Truss (Pratt Type) and find out the following values;

1. Support reactions
2. Forces for the members a, b, c

4 kip 40 kip 40 kip
Y Y y _
Wk Dkip|
/ ¢P A
10—+ 10 10 10—+
Y TEE T
Fig. 4.17: Two Dimensional View of the Bridge Truss (Pratt Type)
Properties:

All members are Japanese | shape = 1 150X75X6

T

200070

Fig. 4.18: Three Dimensional View of the Bridge Truss (Pratt Type)
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Procedure:
1. Geometry (Model creating):
1.1 Open STAAD Pro. software >File = New = Click on Truss ->Write the File Name and select

Location—>Length Units = Foot, Force Units = Kilo Pound = Next > Add Beam —>Finish. (Fig:

4.19)
Mew >
[Jspace File Mame:
[JPlane
[ Fioar |Hoof truss
Location:

|D:\CEE LAB Documents’8. Lab Clas|

A TRUSS structure consists of truss members which can have only axial member forces
and no bending in the members.

Length Units Force Units
(O Inch (O Decimeter (O Pound (0 Newton
(®) Foot () Meter (®) KiloPound {C) DecaNewton
O Milimeter () Kilometer (O Kilogram (O KiloNewton
() Centimeter (D) Metric Ton () MegaMewton
< Back Next = Cancel Help

Where do you want to go 7

[]Add Plate

[Add Salid

[JOpen Structure Wizard
[JOpen STAAD Editor
[ Edit Job Information

drawing tools and spreadsheets.

Begin building your model by creating new joints and beams using the construction grid,

< Back Cancel Help
Fig: 4.19
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1.2 Now close the Default Grid window = For 1% Node point input (X=0, Y=0,Z=0) - Select Node
(in View window) by using node cursor > Translational Repeat =>Global Direction =X =>No. of
Steps = 6 > Spacing=10 >Click on Link Steps >OK. Again select the members 2 to
5->Translational Repeat > Global Direction =Y >No. of Steps = 1 - Spacing=12 ->Click on
Link Steps > OK. (Fig: 4.20)

1.3 Add beam from point 1 to 7 and 10 to 6. (Fig: 4.21)

1.4 Now Select the Nodes 1 & 6 (in View window) by using node cursor > Translational Repeat >
Global Direction =Y - No. of Steps = 1 - Spacing= -15 (-ve)-> Click on Link Steps = OK
(Fig: 4.22). For 3D select the whole structure by using beam cursor > Translational Repeat ->
Global Direction =Z = No. of Steps = 1 - Spacing= 20-> Click on Link Steps - OK

Step Spacing QK
1 5.000 Cancel
2 5.000 Help
3 5.000
™ “Step 2 4 =000
5 EX [] Renumber Bay
Link Steps
[JOpen Base
Global Di i Generation Flags
obal Direction Mo of Steps: |5 "% @ Al () GeometryOnly
@®x Oy OZ Default Step Spacing: |5 ft () Geomeiry and Property Ony

| Bridge truss - Modes E@
Zz

10
1 2 3 4 [ B
Translational Repeat 4
step | Spacing
3 = 000 Cancel
Help
[1 Renumber Bay
Link Steps
Open Base
- - Generation Flags
Global Direction Mo of Steps: EI @Al (O GeometryOnly
Ox ®y Oz Default Step Spacing: ft () iGeometry and Property Onby

Fig: 4.20
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Geometry Commands  Analyze Mode

Modes
Snap/Grid Node 4
& Insert Node... Set Mew Member Attributes...
Add Plate MW A dd Beam from Point to Point
Add Solid » = o
Y T — i+ Add Beam between Mid-Points
Cramm L ulnear s T Add Beam by Perpendicular Intersection
Connect Beams Along L3
Ff Create Infill Plates -_!:f Add Curved Beam

Create Parametric Models...

miw Translational Repeat... Add beam from pOInt lto7 and 10to 6

&N Circular Repeat...

& Generate Surface Mesh
Generate Plate Mesh
Generate Slab/Wall Connection

Move... L4
(= Rotate...
-ﬁ— Mirror...
/.'\ Stretch Selected Member(s)

Intersect Selected Members L4

Merge Selected Members
Merge Selected Modes

Renumber »

Split Beam

Break Beams at Selected Modes

Run Structure Wizard 1 4 ‘E

Fig: 4.21
q 4 6
Translational Repeat =
Step Spacing I oK I
1 —10.000 Cancel
Help

[] Renumber Bay
Link Steps
Open Base

Global Di i Generation Flags
obal Direction Mo of Steps: E (@ Al () GeometnyOnhy

Ox @y OZ Default Step Spacing: |-10 i () Geometry and Property Oy

Fig: 4.22

2. General (Define & Assign):
2.1. Property - Section Database > Japanese—> | Shape—> | 150X75X6 > Material = STEEL-> Add
—>Close then for Assign select the property and click on Assign to View > Assign = Yes. (Fig:
4.23)
2.2. Support > Create >Fixed ->Add - Now for Assign click on the Support type ->Select the
Support point in Truss > Assign to Selected Nodes = Assign - Yes.
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| = |17 Properties - Whole Structure ¥ | Section Profile Tables X
2|t
E E_ s Steel  Coldformed Steel  Timber  Aluminum
ection
x| 2 Eea e @ rorcan ~| (SR
. . @ American Steel Joist i
T || Ref Section Material & fusralan Select Beam _ et
@ Brai (®) 5T (Single Section from Table)
i |1 Rect 15000000 CONCRETE & b HO0X75X5 A | )T (Tee Section Cutfrom Bearm)
gy sh N25X75X5.5 D (Double Frofle)
& @ Canadian 1150X75X6
‘% Chinese 1180X100%6
H:H fui} @ Dutch 1200X100X7 (O)CM (Composite Section)
= | @ European 1150X125X8.5 0
ol @ French 1250%125%7.5
T g German 1300x%150%8 0
o e @ indian 1200%150%9 =
= i:l [ Japanese 1250%125X10 ¥ -
0] e . - |l H Shape
/| Highlight Assigned Geomet i
7 | gnig g Ty View Table
) [ T Shape ) (O TC (Top Cover Plate)
- Material
3 Edt.. Dele... -l Chamel A ateria () BC (Bottom Cover Flate)
<| g ~ [ Angle STEEL | (OB (Top & Bottom Cover Plate)
c .
E E Values. . Section Database Define.. - [l Tube =
@ g - Pipe
2l 5 Materials... Thickness... Uger Tabe. . - [W Rectangular Hollo
9 ) - [ Square Hallow
4| g Assignment Method [l Gircular Hollow
¥ — N
L fasion To Selected Beams () Use Cursor To Assign * dinctl
: ) . ) @ Mexican
L= () Aasign To Edit List (®) Assign To View @ Russian (GOST)
2 @ Russian (STO ASChV
% 2 | | @ South African
of & @ South Korsan
L1} =~ v
1| = < >
-3 Assign Close Help
Fig: 4.23

2.3 Now Select the whole structure (in View window) by using beam cursor > Translational Repeat
—> Global Direction =Z = No. of Steps = 1 = Spacing= 20 = Click on Link Steps - OK and
then delete extra beams (Fig: 4.24)

Fig: 4.24

2.4 Load & Definitions - Load Cases Details > Add - Loading Type = Dead > Title = Dead Load
or DL > Add - Loading Type = Live > Title = Live Load or LL > Add - Close. (Fig: 4.25)
e DL —>Add ->Self weight —>Direction = Y, Factor = -1->Add ->Close. Then
SELFWEIGHT Y-1 > Assign To View > Assign 2> Yes. (Fig: 4.26)
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For Given loads: Again Live Load or LL > Add ->Nodal Load - Fy =-20 kip >Add >

Fy = -40 kip>Add > Close, then click on defined force and select the required Nodes ->
Assign to selected Nodes > Assign > Yes. (Fig: 4.27)

2.5 Load Combination: Load Cases Details > Add —>Define Combinations - Name

DL+LL

—>Default ai = 1, then select DL, LL and click on >> to send right side from left side. (Fig: 4.28)

Load & Definition

> Primary

#-[D] Definitions

b Load Generation

ﬂ ‘E:f'.;‘:.‘,,,ﬁ'f" i Define Combinations
i Auto Load Combination
Number Loading Type : | Dead v
Reducible per UBC/IBC
Te bt
New.. Edt .. Delete. .
[ Toggle Load
Assignment Method
Assign To Selected Entities Use Cursor To Assign
Assign To View Assign To Edit List
Assign Close Help Add (lose Help
Fig: 4.25
Add Mew : Load Tterns
Load & Definition X
® ght oad #-(D) Definitions
@ Wember Load Direction E Load Cases Details
@ Physical Member Load Ox ®Y Oz : E 1-0L
@ Area Load 8
T [ — ?
@ Plate Loads Factr |1 ||| Load Envelopes
@ Suface Loads
@ Solid Loads !
@ Temperature Loads New... Add... Edit ... Delete...
@ Seismic Loads [ Toggle Load
@ Time History Assignment Method
@ Wind Load Assign To Selected Beams/Plates () Use Cursor To Assign
@ Srnow Load (®) Assign Ta View () Assign To Edit List
@ Response Spectra
@ Repeat Load |
@ Frequency
Assign Close Help

Fig: 4.26
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CEE 330L: Structural Analysis and Design Lab, NSU

Add New: Load ltems Load & Definition W
. Definitions
$sivsi | (U | [ o Covos Detas
0 — | D
B Noe g SELFWEIGHT Y1
L H Support Digplacemen 2L _
@ Venber Load e AR
@ Physical Member Load (D Load Envelopes
@ s Load B |0 kp [0 kit -
@ Foor Load ‘
@ Plte Loacs | |
@ St Loads i) o W ot
@ Soi Loads ' 3 “
@ Temperaure Loads (0 ko |l kit
@ Seismic Loads
@ Time Hstory
@ Vind Load ‘ -
@ Snow Load MNew. .. Add.. Edit ... Delete...
@ Respanse Spectra Esg’ngﬁ:ﬂl'?:;md
@ HEDEET Load (®) Assign To Selected Modes (Z) Use Cursor To Assign
@ Fequency ?Assign To View () Assign To Edit List
Close Help
Fig: 4.27

Add Mew : Load Cases

i Frimary

g

E Load Generation
Define Combinations Load No: Name : |DL+LL |
B Auto Load Combination Type
(®) Nomal General Fomat : | 2, *Li
() SRSs
O nas Factor 1 SRSS Component
Default Generate Combination
Awvailable Load Cazes: Load Combination Definttion: [S] = SRSS
LoadCases | | Factor |
2L
=
>3
<
<
Add Close
Fig: 4.28
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Analysis and Result:
From left side click on Analysis/Print = Static Check or All ->Add - Close
At Menu bar > Analyze > Run Analysis = Go to post processing mode ->Done - Selected load

cases = DL+LL >Apply >OK. (Fig: 4.29 & Fig: 4.30)

For Support Reactions use node cursor and double click on the support point ->Reactions. Then

get the Table for all Support Reactions.

For Beam Forces: From left side click on Beam ->from Graphs find out Axial force by clicking

on required Beam.

Analyze  Mode Window Help

I 2 | |[M s al et o7 WA BTSN
By
++ Proces==ing Global Stiffnes=s Matrix 13:47:32
++ Finished Processing Global Stiffness Hatrizx. 150 m=
| ++ FProcessing Trisngular Factorization. 13:47:32
E ++ Finished Triangular Factorization. 100 m=
= ++ Calculating Joint Displacement . 13:47:33
++ Finished Joint Displacemsent Calculation. 160 m=
++ Calculating Member Forces. 13:47:33
++ Analvsi= Successfully Completed ++
++ Creating Displacement File (DSP) . .. 13:47:232
++ Creating Reaction File (REA) . 13:47:33
++ Calculating Section Forces1-110. 13:47:33
++ Calculating Section Forces2 . 13:47:33
++ Calculating Section Forces3 13:47:232
++ Creating Section Force File (EMD) . 13:47:33
++ Creating Section Displace File (SCH) . .. 13:47:34
++ Done. 132:47:34
0 Error(=). 2 Warning(=). 0 Hotel(=)
++ End STAAD Fro Run Elapssed Tims = 41 Secs=
BE-2 anl
L4 >
() Wiews Dutput File
@ (®) Go to Post Processing Mode
() Stay it Modeling Mode Dane
Fig: 4.29
esults Setup *

Loads Range Result View Options

Defined Envelopes
(®) Envelope of Load Cases in Selected List

Load Cases
Awailable: Selected:
10L ) 3DL+LL
2L :
>
<
<

Apply

Help

Fig: 4.30
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CHAPTER-V

MULTI STORIED BUILDING FRAME UNDER ALLLOADS

Objective: Analyze the following 7-Storied residential building under all loads and Columns, Beams
forces and support reactions for foundation design.

————————————n n————————————n A————————————n n————————————n A————————————n

| DRAHNGROOW DRAHNG ROCH |
; nr YA AT nrey ;
-
N TR .
AL ToLHL C.TOLET I o
= T S
.
KITCHEN HTCHEN
- 90X 70" -
i DABGROOM DHNGROOM i W 1
i X POL \ i
| |
|- ATOLET I ]
.== i
l 03] C.HD :
| WED . D I
| XN bl el X0y |
| |
L= =
i B -
VER VER
104 x 3" 106X 30

Fig: 5.1 Typical Floor Plan
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]L 133" ][ &3 | g 5 | &l3" ][ 133" _ll
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-I |
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> | |
- | | | |
Cl k a Cl
_ _ 2 _ _ Y . -
133" I 210" I 133"
Fig: 5.2 Column LayoutPlan
OHWT
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l I o ﬁlj Roof
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1 6ith Floor

]
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i | -
4th Floor
T 3rd Floor
I I || T 2nd Floor
T 1st Floor]|
f T t - T Groupnd floor Level

Veranda g © Veranda :[
06— 06— I N R N -

Fig: 5.3 Beam LayoutPlan Fig: 5.4 Elevation View
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Table 5.1 Geometry and Loads:

Properties: Load Definitions:
Column: C1=12"X15” 1. Seismic Definition: (Dhaka zone)

C2=127X18” EQx & EQz

C3=127X20” 2. Wind Definitions: (for Dhaka)

Wx & Wz
Beam: GB = 107X18” *Wind speed for Dhaka zone = 210 km/hr = 130 mile/hr
FB =107X20” 3. Dead Load:
Varenda Beam: 6” X 6” Self weight (Factor=1)
Slab weight = 75 psf (For slab thickness= 6”)

» All supports are fixed support Floor Finish (FF) = 30 psf
*  Bottom story height = 8°-0” Partition wall load (PW) = 25 psf
* Typical story height = 10’-0” Wall load on beams (W) = 416 Ib/ft (for 5 brick wall)

* Top story for lift & stair = 8’-0” 4. Live Load: LL =40 psf

Load Combinations:

UFL =DL+LL

FDL =1.2*DL+1.6*LL

FDLEQx = 0.9*DL+1.2*LL+1.32*EQx
FDLEQz = 0.9*DL+1.2*LL+1.32*EQz
FDLWxX = 0.9*DL+1.2*LL+1.2*Wx
FDLWz = 0.9*DL+1.2*LL+1.2*Wz

Procedure:

1.  Geometry (Model creating):

1.1 Open the STAAD Pro. software and click on New Project ->Space —>File name —>Location
(select your file location to save) = Length unit select Foot and KiloPound > Next > Add Beam
—>Finish.

1.2 Column & Beam Layout:

121

122

1.2.3

Close the default Grid system and at the right side input your first node point coordinates
as (XY 2)=(0 0 0) (Figure: 5.2). After than select the node by using node cursor
—>Geometry > Translational Repeat > Select Global Direction = X > No of Steps =3 >
now write down the column spacing from your Column Layout Plan as (Stepl =19.5,
Step2 =8.5, Step3 =19.5) > Link Steps >OK. (Figure: 5.2)

After than select the total beam by using Beam cursor >Geometry —>Translational
Repeat - Select Global Direction = Z - No of Steps = 1 - now write down the column
spacing from your Column Layout Plan as (Stepl =15.667 ft) ->Link Steps ->OK.
(Figure: 5.3)

Now select the column node no 5 & 8 from the 2™ row ->Geometry - Translational
Repeat > Select Global Direction = Z - No of Steps =2 = now write down the column
spacing from your Column Layout Plan as (Stepl =12.25, Step2 =11) ->OK (Figure:
5.4). Again select the column node no 9 & 10 by using node cursor ->Geometry
—>Translational Repeat > Select Global Direction = X - No of Steps =3 - now write
down the column spacing from your Column Layout Plan as (Stepl =13.25, Step2 =21,
Stepl =13.25) > OK (Figure: 5.5)
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For create beam layout: Go to Geometry ->Add Beam - Add Beam from Point to Point
and then connect the nodes points each other as the given Beam layout plan. Again for
interesting beam go to Geometry >Add Beam ->Add Beam by Perpendicular
Intersection. (Figure: 5.6 and 5.7)

Veranda Create: Now select the node no 12 > Geometry - Translational Repeat - Select
Global Direction = X-> No of Steps =1 - now write down the Veranda length as (Stepl
=-10.5) >OK (Figure: 5.8).

Again select the beam from node no 12 to 19 by using beams cursor ->Geometry
->Translational Repeat > Select Global Direction = Z = No of Steps =1 - now write
down the now write down the Veranda width as (Stepl =3) ->Click on Link Steps >0OK
(Figure: 5.9). And similarly create another Veranda.

Now Story Create: Select whole structure >Geometry -> Translational Repeat - Select
Global Direction = Y- No of Steps =8(7 stoy+1 is bottom story for base)—> Default Step
Spacing = 10(Typical story height) and Stepl = 8) =>Click on Link Steps 2> OK (Figure:
5.10).

Then delete the unnecessary columns from veranda and inside of the plan by selecting
them (use Delete button from keyboard).
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2 General (Define & Assign):
2.1 Support Create and Assign:
2.1.1 Click on View from +Z ->Select the all bottom Story beams -> Delete > Ok > Yes
2.1.2  From left side Click on General - Support ->Create - Fixed > Add. (Fig: 5.11)
2.1.3 Select S2 Support 2 >Select all bottom Nodes by using Node Cursor —>Assign to
Selected Nodes > Assign > Yes. (Fig: 5.12)
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2.2 Property (Beam, Column creates):

2.2.1  Same processes follow for other columns and Beams.

2.2.2 Column & Beam Define: From left side Click on General —>Property ->Define
->Rectangle >YD=1.25 ft, ZD=1 ft (For column C1) > Add. (Fig: 5.13)

2.2.3  Same processes follow for other columns and Beams.

2.2.4  (Here YD is depth of Beams and columns and ZD is width of Beams and columns)

2.3 Column & Beam Assign: Click on each of the property - Select the member from view as your
given layout = Assign to selected beams - Assign = Yes.

2.4 Load & Definition: In STADD Pro. must be follow the sequence as 1. Earthquake, 2. Wind load,
then 3. Dead load and 4. Live load.

2.4.1 Earthquake Definition: Load & Definition > Definitions - Seismic Definitions - Add
—>Type: UBC 1994 ->Then write down the parameter values as your given data building
category > Add->Self weight Factor = 1->Add Then click on Floor Weights ->Pressure
= -0.17(Slab weight 75+FF 30+ PW 25+LL 40 =170 psf= 0.17 ksf) and Y range 0 to 78
—>Add >Close. (Fig: 5.14 and Fig: 5.15)

2.4.2 Wind Load Definitions: Load & Definition - Definitions >Add > Type:1, Comments:
X-Direction >Add = TYPE 1, Comments: Z-Direction = Add—> Close.

a. TYPELl: X-Direction>Add ->Calculate as per ASCE-7->Input the Common
data>Apply-=>Main building data according to your Project>Apply -0k Add
—>Close. (Fig: 5.16 and Fig: 5.17)

b. Same process follow for TYPE2: Z-Direction.

2.4.3 Load Cases Details:

Add >Number =1, Loading Type = Seismic, Title = EQx =>¢

Number =2, Loading Type = Seismic, Title = EQz > Add

Number =3, Loading Type = Wind, Title = WX > Add

Number =4, Loading Type = Wind, Title = WZ > Add

Number =5, Loading Type = Dead, Title = DL > Add

Number =6, Loading Type = Live, Title=LL ->Add >Close

2.4.4  Assign all loads as
e EQx 2>Add ->Seismic Load - X-direction, Factor =1
e EQz > Add > Seismic Load - Z-direction, Factor =1
o WX >Add >Wind Load ->X-direction, Factor =1 ->Y Range, Minimum =8,

Maximum = 78 > Add->Close

e WX ->Add >Wind Load ->Z-direction, Factor =1 Y Range, Minimum =8,
Maximum = 78 ->Add—>Close

e DL —>Add->Self weight &> Factor= -1 >Add->Close >?SELF WEIGHT Y-1
—>Assign to view = Assign

e DL >Add->Floor Load - Pressure (input total floor load with negative sign) then Y
Range, Minimum =8, Maximum = 78 ->Add—>Close

e LL >Add->Floor Load - Pressure (input total floor load with negative sign) then Y
Range, Minimum =8, Maximum = 78 - Add->Close

2.5 Load Combinations: Load cases details >Add - Define Combinations ->Name: DL+LL or
other combinations as required then select the load name from the Available load cases and send
from left to right side = Input necessary factors > Add->Close. (Fig: 5.21). Otherwise use the

Auto Load Combinations according to ACI Code and Add.
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Analysis and Result:
From left side click on Analysis/Print = Static Check or All ->Add - Close
At Menu bar > Analyze > Run Analysis - Go to post processing mode ->Done - Selected load

cases = DL+LL >Apply >OK. (Fig: 4.29 & Fig: 4.30)

For Support Reactions use node cursor and double click on the support point >Reactions. Then

get the Table for all Support Reactions. (Fig: 4.31)

For Beam Forces: From left side click on Beam ->from Graphs find out Axial force by clicking

on required Beam.

Analyze Mode Window Help
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